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COPYRIGHT © 1995 MERIT INDUSTRIES, INC.

TSB11 9-27-95

Technical Service Bulletin

1

Technical Service

Technical Service

Bulletin

Bulletin

Date: 9/27/95

merit industries, inc.

Problem:

Monitor is inoperative after power-up.

Games affected:

All Megatouch games using Type 19 Ducksan monitors.

Symptoms:

After power-up, you can hear the fan running and see the
power supply light, but there is no picture.

Cause:

Fuse on monitor chassis has blown.

Solution:

Replace existing fast-blow 3 amp 250V fuse with a slow-
blow 3 amp (or 3.15 amp) 250V fuse (5 x 20mm). If you
do not have the proper fuse, call Merit Customer Service
for assistance: 1-800-445-9353 (Merit part # EC3004).